XM8 Server Administration Latest Topicshttps://exile.majormittens.co.uk/forum/201-xm8-server-administration/XM8 Server Administration Latest TopicsenThe option to rename the server is not appearinghttps://exile.majormittens.co.uk/topic/27627-the-option-to-rename-the-server-is-not-appearing/
The option to rename the server is not appearing
I followed the steps of the tutorial, but in the part of renaming, this option is not shown!

Sem título.png

27627Fri, 15 Feb 2019 23:24:29 +0000
Monthly Message Limithttps://exile.majormittens.co.uk/topic/23667-monthly-message-limit/ Can we pay monthly to push more notifications per month?

23667Fri, 07 Jul 2017 04:11:39 +0000
XM8 don't send noifications to Mobile APPhttps://exile.majormittens.co.uk/topic/23896-xm8-dont-send-noifications-to-mobile-app/ I have an issue with XM8... When event happend, XM8 don't send notifications, but on side server the config is OK...

I suspect that xm8.exile.majormittens.co.uk is blocking someting of my address for request to XM8 app...

rpt log say:

10:14:19 CallExtension loaded:   XM8 (/srv/arma3/@ExileServer/XM8.so) [P▒▒▒*▒▒]
10:14:19 "ExileServer - XM8 mesage sent: {""r"":[""76561198068980812""],""m"":""flag-restored"",""t"":""test""} ([0,'Config OK MainThread started'])"
10:22:43 "ExileServer - XM8 mesage sent: {""r"":[""76561198068980812""],""m"":""base-raid"",""t"":""test""} ([0,'OK'])"
10:32:52 "ExileServer - XM8 mesage sent: {""r"":[""76561198068980812""],""m"":""flag-stolen"",""t"":""test""} ([0,'OK'])"

XM8Log say:

[0,'Config OK MainThread started']
[27-7-2017_11-15-19] XM8Log: Data sent to server: {"r":["76561198068980812"],"m":"flag-restored","t":"test"}
[27-7-2017_11-15-19] XM8Log: Server returned:
MESSAGE: {"r":"fail"}

tcpdump dst port 80 say:

12:21:40.915151 IP Arma3server.45178 > orion2815.startdedicated.de.http: Flags , seq 4162387452, win 29200, options [mss 1460,sackOK,TS val 140513016 ecr 0,nop,wscale 7], length 0
12:21:41.164636 IP Arma3server.45178 > orion2815.startdedicated.de.http: Flags [.], ack 1504358293, win 229, options [nop,nop,TS val 140513078 ecr 817354214], length 0
12:21:41.164717 IP Arma3server.45178 > orion2815.startdedicated.de.http: Flags [P.], seq 0:310, ack 1, win 229, options [nop,nop,TS val 140513078 ecr 817354214], length 310: HTTP: POST /api/sendMessage HTTP/1.1
12:21:41.416918 IP Arma3server.45178 > orion2815.startdedicated.de.http: Flags [.], ack 156, win 237, options [nop,nop,TS val 140513141 ecr 817354277], length 0
12:21:41.459073 IP Arma3server.45178 > orion2815.startdedicated.de.http: Flags [.], ack 157, win 237, options [nop,nop,TS val 140513152 ecr 817354277], length 0

But never get any message in my phone, but I send broadcast message from the web xm8 and work correctly...

I running XM8.so 64bit linux version compiled.

NOTE: At XM8.exile.com web say this message:

Connection Problems

Our backend servers have never received a notificiation from your Arma server.

Check our forums for help.

But, on the forum don't have nothing solution about this, only little thing that I was probe with this...
_nslookup xm8.exile.majormittens.co.uk resolve to Address:
_XM8.so have correct permissions, but it is the same because arma3server run with root owner
_My server is behind a firewall, but outgoing any ports and protocols are open, only incoming traffic are filtered except arma ports 2302-2305... Outgoing connections to port 80TCP and UDP are not filter...
_Have static IP address
_Have latest Exile and ExileServer version "Lemon"

I wish someone could tell me what's going on, and tell me what is the correct format of the config file "@ExileServer/ExileXM8Key.cfg" because when I download file from the web, the file have 1 line with a code of 80 lines only.

Offtopic: Is my first thread, if this does not go here, please tell me which sub-forum should I write...

Tanks 4 help!


23896Thu, 27 Jul 2017 13:47:57 +0000
XM8 App broadcast limithttps://exile.majormittens.co.uk/topic/24458-xm8-app-broadcast-limit/ Hey,

Would it be possible to get the monthly limit increased? I figured this might be a "paid" option but I cant seem to find anything.


Many thanks :D

24458Sun, 24 Sep 2017 09:24:41 +0000
No notificationshttps://exile.majormittens.co.uk/topic/27454-no-notifications/ Just a few questions....

1.  Does anyone know if the Exile Server Manager will cause the XM8 app not to work?

2. I am running extdb3 64 bit.  Do I need to be running the 64 bit xm8 dll?

I have setup the server and the broadcast works but I get no notifications on my phone.  I can see in the rpt file where it sends the notifications but my Server shows never transmitted in the XM8 server console.

I went to amibehindaproxy.com and it says I am not behind a proxy.  I checked my ip address in the IPv4 stack in adapter properties and is the same ip address as what shows up for my public ip address.

The address is  I noticed my default gateway is so I tried that as my proxy but it didn't work either.

Any other advice on how to trouble shoot this problem would be great.  ESM works like a champ so I cant imagine anything being blocked on the firewall but just in case, I set up an outbound rule to allow all outbound trafic for all protocols and ports.  Still no love.

Thanks for your assistance in this matter.

27454Thu, 20 Dec 2018 04:06:31 +0000
ESM Bot and XM8 Apphttps://exile.majormittens.co.uk/topic/27453-esm-bot-and-xm8-app/ Does the XM8 app see territory fees paid with the ESM bot?  I'm trying to determine if my XM8 app is working correctly with my server but I'm at work and can't log in to the game right now.  I recently setup the XM8 app on my server and I get the server broadcasts that I send for testing but if I pay territory fees using ESM bot I do not get a notification from XM8 app.  The fees are being paid, I have verified this.  I have not paid territory fees in game to test the XM8 app yet because I am at work.  It may be working in game but just doesnt recognize payments made with ESM bot.

27453Wed, 19 Dec 2018 19:52:38 +0000
Help setting up XM8 Apphttps://exile.majormittens.co.uk/topic/27266-help-setting-up-xm8-app/ i have followed the instructions from this thread and triple checked everything: 

 and i still get an error saying that it cant find the server, even after completely disabling windows firewall to be sure it wasnt a port issue or something. No idea what to do, any ideas? 


27266Mon, 29 Oct 2018 20:13:54 +0000
Auto run in XM8https://exile.majormittens.co.uk/topic/26765-auto-run-in-xm8/ I can autorun while i am in the XM8, then i go to CCTV and choose a camera! Then i run inside bases/houses and everything. Someone know this issue?

I use the Infistar APP function.

26765Tue, 17 Jul 2018 07:42:10 +0000
XM8 fails to open ExileXM8Key.cfg [linux]https://exile.majormittens.co.uk/topic/26556-xm8-fails-to-open-exilexm8keycfg-linux/ It seems there is a bug in the Linux build of `xm8.so` with locating the `ExileXM8Key.cfg` on the disk. Using `strace` it can be seen that `xm.so` is attempting to open the file using a relative path, which is incorrect as the current working directory is `/home/steam/arma3`. Clearly the file exists as `stat` succeeds.

steam@arma:~$ strace ./start.sh 2>&1 | grep ExileXM8Key
stat64("/home/steam/arma3/@ExileServer/ExileXM8Key.cfg", {st_mode=S_IFREG|0644, st_size=81, ...}) = 0
stat64("/home/steam/arma3/@ExileServer/ExileXM8Key.cfg", {st_mode=S_IFREG|0644, st_size=81, ...}) = 0
open("ExileXM8Key.cfg", O_RDONLY)       = -1 ENOENT (No such file or directory)

Please advise.

Edit: I worked around this bug by sym-linking the file in the arma3 directory:

ln -s \@ExileServer/ExileXM8Key.cfg ./

While I am at it, can I please request that xm.so be rebuilt against libcrypto 1.1 as 1.0 is quite old and most modern distributions have dropped support for it.

26556Thu, 07 Jun 2018 00:48:30 +0000
Connection Problemshttps://exile.majormittens.co.uk/topic/20415-connection-problems/ Hello!

At first sorry for my bad English, not my main language ;)

Can't recognize what's a problem with connection =(

Connection Problems

Our backend servers have never received a notificiation from your Arma server.

Check our forums for help

I don't have any blocking for outgoing connections.

Arma 3 server is ok too.


[RU] A3ERP - Exile [BETA]


What I need to do?



Why app is not available for Lenovo A606? Google Store said me that. Is it true?

20415Sun, 01 Jan 2017 04:01:52 +0000
Is the app still working ?https://exile.majormittens.co.uk/topic/25451-is-the-app-still-working/ Hi there,


the app still work? Because I made all the thing in the HOW TO but always an error in my android app: Invalid server code, please try again later.



25451Sun, 14 Jan 2018 20:41:02 +0000
XM8_x64.dll installed - Wont accept keyhttps://exile.majormittens.co.uk/topic/25243-xm8_x64dll-installed-wont-accept-key/ XM8_x64.dll is giving me Malformed Config File (Using the dll that Kuplion linked to back in October)

21:39:06 CallExtension loaded: XM8 (C:\A3Servers\ExileLingor\@ExileServer\XM8_x64.dll) [|t_aX]
21:39:06 "ExileServer - XM8 mesage sent: {""r"":[""XXXXXXXXXXXXXXXXX""],""m"":""protection-money-paid"",""t"":""Meseeeeeeks""} ([1,'Malformed config file'])"

Have renamed the file to XM8_ExileXM8Key.cfg as per the instructions:

Key works fine with the 32-bit DLL

Anything Im missing? or does this DLL simply not work yet ?
This DLL also is not blocked.


Running on Windows Server 2016 Standard, all vcredist packages installed (both x86 and x64 versions where available)

25243Thu, 21 Dec 2017 20:00:31 +0000
[Request] XM8_x64.dllhttps://exile.majormittens.co.uk/topic/23980-request-xm8_x64dll/ Hello,

I tried contacting @Grim but I don't get a response of him. Does anyone have a 64 bit version of the XM8.dll?

Thanks for responding :)

23980Fri, 04 Aug 2017 15:21:21 +0000
Remove servers from accounthttps://exile.majormittens.co.uk/topic/24885-remove-servers-from-account/ I need and removed from my account.  Both server ips have changed and everything is set and running for them.

24885Wed, 15 Nov 2017 10:42:05 +0000
Wrong Ip and Server name added to my account. need to fix asap please!https://exile.majormittens.co.uk/topic/24952-wrong-ip-and-server-name-added-to-my-account-need-to-fix-asap-please/ Hello, was trying to setup my XM8 app. Having a problem, it says address already in use. i looked into it and found this address and name of server
it is not my addres and server name. Bandit123 <---this is what is has.  has 106 at end. mine is 100. please fix! So i can get my 
app running. below is my info on my server. is my address.
Arma 3 Server


24952Fri, 24 Nov 2017 07:53:54 +0000
Not send broadcast message(limit of char)https://exile.majormittens.co.uk/topic/24933-not-send-broadcast-messagelimit-of-char/ Hi, what is this?


24933Tue, 21 Nov 2017 09:38:36 +0000
Did not receive mail for verification EMAIL.https://exile.majormittens.co.uk/topic/19228-did-not-receive-mail-for-verification-email/ Hello, I use the GOOGLE translation to communicate, so there may be translation is not the right place, please forgive me.

I ran into an issue where I registered an XM8 admin account but did not receive EMAIL authentication (I checked the trash and other classified messages to make sure I did not miss it).

So I can not log it.

I tried resetting the password, and I could receive a message to reset the password, but did not receive a message to verify EMAIL.

Please help me, thanks.


19228Sat, 29 Oct 2016 15:21:32 +0000
Problems connecting through the phone.https://exile.majormittens.co.uk/topic/22902-problems-connecting-through-the-phone/ Hello!

Configured everything as described, everything seems to work, shows the amount of gear when paying territories, writes the logs but, when you try to connect the phone via the password server fails with the following: Epic Fail invalid server code!

How can it be not true, if everything is correct?

Can the code on my server to interfere with the same code on another?

22902Wed, 17 May 2017 21:59:26 +0000
Activation Email Not Senthttps://exile.majormittens.co.uk/topic/24704-activation-email-not-sent/ I tried to register an XM8 account but I have not received the activation email.

24704Tue, 24 Oct 2017 10:27:37 +0000
server already existshttps://exile.majormittens.co.uk/topic/24274-server-already-exists/ getting this error...tried to register before but couldnt restart server at the time....Seems i cant do it anymore now ?


help would be great :) thanks


24274Mon, 04 Sep 2017 23:36:48 +0000
Second IPhttps://exile.majormittens.co.uk/topic/22414-second-ip/ Hey all,

So, We have a server with OVH. Sadly with OVH you cant move the main IP to another server if you wish to upgrade but you can with a failover IP/second IP

How do we set it up so it uses the failover IP instead of the main one? Iv looked in the configs for something on the lines of IP: but found nothing.

Any ideas?


22414Fri, 14 Apr 2017 12:50:35 +0000
<![CDATA[New server & Getting Error Server Exist]]>https://exile.majormittens.co.uk/topic/23983-new-server-getting-error-server-exist/ - 2402 - 2403

23983Fri, 04 Aug 2017 19:55:32 +0000
Server already existshttps://exile.majormittens.co.uk/topic/22644-server-already-exists/ I've just recently rented a server for Arma3 Exile and tried to sign up for the XM8 app however it says that the server already exists.

How do i go about getting this sorted so that i can get my server registered.

22644Tue, 02 May 2017 15:50:38 +0000
Question about InfiSTAR's XM8 Custom Appshttps://exile.majormittens.co.uk/topic/23917-question-about-infistars-xm8-custom-apps/ I'd like to know how to create an app to deploy a quad bike, and it uses 1 duct tape from your inventory.

23917Sat, 29 Jul 2017 16:53:00 +0000
Server IP Address Changehttps://exile.majormittens.co.uk/topic/19052-server-ip-address-change/ I have a new static IP for my server. Is there a way to update the existing XM8 server details to change the IP address?



19052Fri, 21 Oct 2016 12:54:06 +0000